Announcement

Collapse
No announcement yet.

InDesign CC 2017 export to PDF leaves some text outside of frame

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • InDesign CC 2017 export to PDF leaves some text outside of frame

    Hello everyone.

    I have a quite large .ai file (a map) which I have linked several times inside an InDesign document. Basically I'm using the same map file and isolate a different part of the file in each of several pages. It looks great inside InDesign, when I export it to .PDF though, I've noticed (some but not all) of the map text -street names- not being cropped by the page frame. This happens ONLY with the text and not with any of the rest of the artwork. I see white space around the frames and some text in black. Seems kind of weird.

    What am I doing wrong? I must say the ai. map file is quite large (in case this has anything to do with it).

  • #2
    Is the text actually in the AI file? or did you add it in InDesign?
    When you say ''frames'' how were those created?
    When saving to PDF, under Compression, is the box checked for Crop Data to Frames?
    Can you post a pic?

    Comment


    • #3
      The text in inside the AI file. I imported the .ai file through the File -> Place command, resized and placed the frame created and finally resized and placed the ai file inside the frame. I checked the "Crop Data to Frames" option and it is checked.

      I included a screenshot (pixelated for the most part since it includes commercial work). As you can see only some of the text seems to bleed outside the frame. I repeat, this bleeding does NOT appear inside InDesign but only when I export to .PDF. What I find odd is that this happens only to the text and none of the other objects (roads, squares etc) is affected.

      I have to say that the pages where I placed the ai link for the first time look fine, without the bleeding. Then I copied the frame (with alt-drag) to the other pages I needed (since the frame size is the same at all times and I only have to move the linked ai inside the frame to represent a different part of the map and got this bug. I did a short test right now, I deleted one of these 'buggy' frames and placed the ai file again from scratch. The problem persists.

      What could I be doing wrong? Should I check anything in the text layers inside my .ai files or something?

      Click image for larger version

Name:	testFrame_Pixel.jpg
Views:	11
Size:	162.4 KB
ID:	21388
      Attached Files

      Comment


      • #4
        Sorry for the multiple identical attachments but I seem to have an issue with the forum. Whenever I click on "Post Reply" there is a "Working..." pop-up on top of the page and an ongoing circle that goes on forever. I had the same issue with Chrome, Edge, I even tried Internet Explorer. I wasn't sure my post registered.

        Comment


        • KitchWitch
          KitchWitch commented
          Editing a comment
          The forum tends to do that. When I post, as long as it gets to the ''working'' and spinning stage, I refresh the page and my post is always there.

      • #5
        Did you try replacing the whole frame, not just the link?
        Or a copy/paste instead of an option drag?
        Can't say I've seen that one before.

        Comment


        • #6
          I tried both, nothing changes.

          Comment


          • #7
            Try this…
            Replace the ai file in InDesign, but use the shift to see the import options.

            Probably at the bottom of the import options window you will see an option "transparency". See that this unchecked.

            Normally this solves the problem

            Comment


            • #8
              Is there anything else to try? I have the same issue as Graphicman80. I tried unchecking "transparency" and reimporting the .ai files but it had no effect

              Comment


              • #9
                Hi Oldtoby and welcome to GDF.

                We ask all new members to read very important links here and here. These explain the rules, how the forum runs and a few inside jokes. No, you haven't done anything wrong, we ask every new member to read them. Your first few posts will be moderated, so don't panic if they don't show up immediately. Enjoy your stay.
                Shop smart. Shop S-Mart.

                Comment


                • #10
                  I got busy with other projects and forgot to check on this topic again.

                  The unchecking of the transparency option save my day. Tons of thanks Carlo!!

                  Comment


                  • #11
                    glad to help

                    Comment

                    Search

                    Collapse

                    Sponsor

                    Collapse

                    Incredible Stock

                    Latest Topics

                    Collapse

                    GDF A division of Mediabistro Holdings Adweek | Mediabistro | Clio | Film Expo Group Contact Us | Terms of Use | Privacy Policy Copyright © 2016 Mediabistro Holdings
                    Working...
                    X