Adobe Illustrator - Transform again on the fritz?

In Adobe Illustrator, I use the transform again tool a lot during my day to day and seemingly recently, it hasn’t been affecting live or outlined type* when it will affect any other regular object. Has anyone come across this on their own or know how to fix it? It will continue to transform the text if you scale up or down as well repeating moves but when scaling objects to certain sizes using the guides and then replicating the same growth on the text object doesn’t work.

  • I’ve tried ungrouping, releasing the compound path, tried intersecting the shapes, the menu command

Hmmm…assuming I understand your explanation of the problem, I can’t reproduce it here.

Have you tried a preferences reset?

I’ve replicated the problem. I can see a reason for not working on editable type but very odd that it doesn’t work on outlined type.

Type 2 separate lines of text
Outline one of them.
Make 2 rectangles. Resize the first rectangle by dragging a corner. Select the next and use CMD+D and it will resize.
But if you select either of the lines of text and hit CMD+D neither will resize. The outlined one should, but doesn’t.

Ah hah!
Checking earlier versions, the problem is there in CC18 and 19, but not very old CS6. Type will CMD+D scale in very old CS6. An error must have crept in during one of the more recent upgrades. I’ve already dumped CC16 and 17 so can’t check those.

That said,
You are SOL.
Submit a bug report to Adobe.

Even more irksome, if you select a line of live type and a box and try to scale it by dragging, the box will resize, the text resizes while dragging but snaps back to original scale when the drag handle is let go.
However outlined type rescales and sticks.

There must be a new feature in here that overides this for live type.

Thought I had a fix (scale strokes and effects) but that ain’t it.
Now I can’t even get the scale by percent box to work, and that’s really not good in my line of work.
A restart of Illustrator fixed the drag scale and the percent scale, but not the commandD scale.

1 Like

Shot in the dark but was the text originally a screen font? Sometimes that or a corruption in the original font file can cause the design elements made therefrom act as “non-native artwork”.

Shot in the dark: pull the outlined text (or live) and save it separately as a smart object?

smart object in Illustrator?

Make a new document. Create the problem area in Illustrator as a separate file and save it (if it has transparencies don’t save as an EPS). Then place it “as a smart object” into the original Illustrator document. It’s a pain, but it might allow you to work with the text.

My best guess would have been a corrupted font at the early stages that “ate” the font geometry. But PrintDriver was able to recreate it, so it couldn’t be corruption.

hmmmmm let me think.

Stupid question - have you tried resetting the bounding box?

Okay, that does indeed replicate it here.

I’m glad you were able to recreate it, I was worried I might be missing something somewhere.

I actually had that exact thing start to happen and then all of a sudden I couldn’t double click to open any new AI docs, dropping in a file to place it was broken and by that point I uninstalled and reinstalled Illustrator.

again neverman a smart object in Illustrator is impossible. That"s a photoshop functionallityy

Year after year, Illustrator continues to get worse as long-existing bugs and limitations aren’t fixed, new glitches are introduced, useless features are added, pointless changes are made and needed improvements remain unaddressed. The worst part is that despite this decline in quality, Adobe continues to siphon money from my bank account.

Meanwhile Affinity Designer is making rapid improvements. I’m really looking forward to the day when I can say goodbye to CC.

The fact that it does it in both of the latest versions but not CS6 means it may be a preference carry over bug…

One that now makes me wonder whether a recent scaling issue was indeed Adobe’s fault for a $1200 misprint…
I might bill them. I’ll let you know how far that gets…

Sorry Carlo, that isn’t true.

A smart object is a pdf based information compiling system. Because you’ve built them in Photoshop does not mean they are exclusive to Photoshop.

If you save the object in Illustrator in a compatible format, you can place it as a smart object back into illustrator.

Sometimes by separating out the “problem” elements in this manner one can identify and solve the problem. Also, sometimes it even fixes the corruption.

But hey, you’re welcome anyway.

Since I was able to reproduce the problem using two rectangles, and two lines of type, I don’t think it’s a smart object problem. I think it’s a dumb Adobe problem that’s crept into the works.

I had my fight for the week with Adobe last Tuesday. If I feel like it after the weekend, I might file a tech support issue and see if I can get one of their minions to reproduce the problem. Right now I’m kicking back with a nice cold cider and pretty much calling it a day.

I don’t think it’s a smart object problem either. It’s just one of the things that you can try if you’re having a problem. Like if your alternator isn’t working you can tap it with a hammer. It’s not a cure, just a potential fix.

Right now the Transform commands seem to be the biggest “area” of consternation for everyone. At least it’s not the color automatically defaulting pre-RIP again.

Oh Gawd, don’t give em any ideas!

Lol! They don’t need any help coming up with bad ideas!

It seems like about 25% of my job is figuring out how the latest version of an Adobe program glitches will affect the print.

Why did the color turn out this way this time?.. Did the font update?..

To go completely off topic,
Bet you were probably around in 2000 when they completely changed the Pantone libraries.
That was a sh!tshow too! Had a half million dollar project go offline for 2 weeks while we sorted that all out.