Can't export objects with screen blending on Illustrator

I need help with exporting on Illustrator :slight_smile: Can’t find an answer anywhere! I am trying to export a large design as PDF (press quality), and I have a layer (gradient circle) with a screen blending. I noticed that when it exports as PDF, it ignores this property and I end up getting a solid shape that covers the elements.

Attached below how it looks like when I export as PDF (tried different settings, PDF 1.3, 1.4 etc) and a screenshot from the program of how it supposed to look like. It looks fine if I export as JPEG…

Any ides how to solve this and export it for print with the screen blending property?

](https://i.stack.imgur.com/ckjbY.png)

Don’t export; Save As PDF and choose PDF/X-4:2010 from the Standard: menu.

Also, if you have spot color(s) in your design (but don’t intend to actually print spot ink), it might help to convert them to Process Color.

1 Like

If this is a large print as in Large Format, as in bigger than 13" x 19"
you may want to contact your print vendor.
A few of the ones I’ve worked with use PDF/x-1A if they take PDFs at all.
Don’t do it unless they tell you.
Most actually don’t take PDF handoffs.
Especially if you are using spot colors and want them profiled to the machine/media.

You may have to flatten the layers with transparencies. You may have to try a few times to get the settings right. Also, often a layer’s sublayer(s) will have transparencies (i.e. global to the overarching layer).

Worst case scenario, save the working copy and rasterize the file.

Of course, either of the methods above are destructive. So you should save a working copy as backup. refer to it when you are done to see if the transparencies caused any color shifts.

Thanks, I did that with the following settings:
ev1
ev2

Same issue has happened.

When I pick the “flatten the artwork” option in the layers section (after selecting them all) nothing happens. I double checked and the problematic two layers (the one with the screen blending and it’s sublayer are 100% transparency.
How do you rasterize on illustrator? I am familliar with the option on photoshop.

It is a large print indeed, I have followed their guidlines (don’t downsample, quality press, no bleeds…). Still happens.

Are you using a spot color?
If so, go to your color palette > ink manager > convert all spots to process.
Any wide format place that wants PDFs and no bleeds isn’t gonna care about your spot colors all that much.

Whups, that was for InDesign. Illustrator is stupid when it comes to color management.
In illustrator, You have to select all of your artwork (unlock it all first,) then Edit > Edit Colors > Convert to CMYK.
Your spots will still appear in the swatch palette but are no longer connected to your art in any way. Unselect your artwork and in the swatch palette, select all unused colors and they will go away. You can then Add used colors to get your CMYK list.

This is a crap method of doing this. If you really want the more correct way of doing a CMYK conversion, at least for a conventional press, you would look up the pantone Bridge values and put them in. Or better yet, check if the conversion is even going to look the way you want it to, and if not, find a bridge color that matches and use those numbers instead.

With wide format, most machines and media are pre-profiled so that in combination they will take a spot color value and come as close as possible without doing any swaps (though if you do want an exact match, you may pay an upcharge for someone to lay eyes on it and tweek if needed.) Most wide format vendors want native files with Solid Coated spot color applied. They will take those files and apply the machine profile necessary for the media being used. You will never have those profiles in your software. You won’t know the model of the machine, the ink set used or the name of the media being fed into it. That’s all proprietary. Any place that is taking PDFs or tifs or jpgs with no bleed is not doing this step.
/rant

1 Like

Yes, for my purposes, I’d consider Illustrator the wrong tool for this job. InDesign is so much better at output of just about every kind.

Thanks but I already tried to “convert to CYMK” after selecting all the layers.
For some reason, I managed to solve it after trying to export it on my laptop (same PDF settings). I don’t know what happened but my laptop has 16GB memory card (instead of 8GB on my PC) and it’s i7 compared to my PC which is i5.
Do you think it can affect the export? Or maybe they have different settings in the program itself?
What a mysterious issue…

How were you viewing the PDF?
What OS is your laptop?
And does your laptop display the PDF from the PC correctly?

Yup, InDesign does a non-destructive conversion. Illustrator, once converted it’s done.

In Illustrator

  1. select the object to rasterize
  2. go “Object - Rasterize”.
  3. A menu will pop up to ask resolution, etc. I generally use 400dpi (300 minimum of course). But I like to have a little more resolution “just in case”. That might not be an option if it is a large print - for memory sakes.

©2019 Graphic Design Forum | Contact | Legal | Twitter | Facebook