CC Font Help

All of the Adobe CC fonts that I have activated are visible in Illustrator, but only some of the fonts are visible in InDesign. I’ve tried logging out and re-logging in, which seems to be the first suggestion when I search for a fix. This doesn’t do anything. It looks like the next fix is uninstalling and reinstalling apps. I’d rather avoid this if at all possible. Any ideas on a fix for this?

I’ve found cursing at Adobe helps, but I will admit that doesn’t actually solve the problem.

Perhaps instead of uninstalling and reinstalling, have you tried logging out of Adobe CC on your computer and then signing back in again. I have no idea if that would fix it, but you never know.

I am brainless at the end of the day. I somehow completely ignored or forgot you had mentioned logging in and out already.

At the least, since the issue is mainly with InDesign, if you were to uninstall and reinstall, I’d start with only InDesign. Could it be a preferences issue? Perhaps resetting those might help:

  • Windows: Start InDesign, and then press Shift+Ctrl+Alt. Click Yes when asked if you want to delete preference files.
  • macOS: While pressing Shift+Option+Command+Control, start InDesign. Click Yes when asked if you want to delete preference files.

This might sound crazy, but try turning on or off the Application frame. I was just telling Sprout that just about every glitch right now in Adobe seems to be cured by that. Maybe temporarily or maybe you get lucky.

@CraigB @PrintDriver

Thanks for the suggestions. Unfortunately, neither nuking the preferences or turning off the application frame worked.

Cursing Adobe only offers temporary relief.

Clear the app-specific font caches:

  1. Close all apps
  2. Search your hard drive(s) for Adobefnt*.lst (that’s dot ELst).
  3. Delete all found files
  4. Launch InDesign and check for a font you noted as an offender

The finger dance that I find works is:

Log of Creative Cloud Online
Go to InDesign and go to Help>Log out
Then Log Out of the Creative Cloud App on your computer


Then login on line in the Creative Cloud
Open Creative Cloud and Login
Open InDesign and use Help>Login to ensure you’re logged in (you’ll know)

It’s weird but it works.
It’s like it has broken a path between InDesign - Creative Cloud Desktop - Creative Cloud Server

@HotButton @Smurf2

Thank you, gentlemen. I have been slammed all day and have not had a chance to give these possible fixes a try, yet. But I will. Fortunately, the projects I’ve had to work on today have not required CC fonts.