Desaturation issue in InDesign

Hey everyone,
I’m new here (I’ll go introduce myself in the correct section after I post this) and I have a little bit of an issue and was hoping to get some help or advice.

I’m working in InDesign and I’m doing a mock-up magazine cover. I worked on an image in Photoshop and imported it in InDesign as an ESP file.

All of my edits and effects imported fine, but I added text on top of the ESP and then tried to add an outer glow to it and the second that I did, it desaturated the image (ESP file) (and also tried a drop shadow and it did the same thing).

I have tried TIFF, JPEG, and PDF in place of ESP and it does the same thing. Are one of my settings off? It’s never done this before and I’ve checked all settings and nothing seems off, but I’m not sure what to do. Even did the InDesign and Photoshop updates and it didn’t fix anything.

Any help would be appreciated, thank you. :slight_smile:

I don’t know if this is causing the problem you’re referring to, but why are you saving a Photoshop image as an Encapsulated PostScript file (EPS)? EPS is an old format meant to bundle up vector and other data into a portable, standardized file. It’s an old holdover format from the early 1990s. If you build something in Photoshop, save it as a Photoshop file (.psd), then import it into InDesign.

If you still have the problem you asked about, let us know, then we’ll go from there.

“Imported”?
Placed and linked?
On it’s own separate layer?
I’ve seen this before and trying to remember why. It had something to do with a transparency and spot color issue, but it wasn’t normal.
Did you try viewing with High Quality display turned on?

That was what I tried first and it did the same thing. I have it saved as every format possible and it had the same issue each time regardless of what it was saved as. I usually use live photoshop files when working in indesign - that’s my normal work flow - this was just my attempt to fix it and it didnt work. I checked the greyscale mode, I checked RGB mode, I checked the settings on the effects, and I checked the export options on all the file format versions and everything was like usual. I worked on another magazine cover and did the sam eprocess, but instead of the EPS file, I used the live photoshop file and used the outer glow effect on text that was over top of it and it never desaturated.

Yes, placed and linked. And on its own layer. I checked the transparency (I saw the same thing) and it was the correct format.

By “desaturate,” do you mean the color of the placed image becomes less vibrant?

If so, does that placed image happen to be an RGB image?

If so, is your InDesign document set up for print? Go to File > Document Setup. At the top of the dialogue box that appears, does it say, “Print”? If so, change it to “Web.”

If that solves the problem, here’s what’s happening.

InDesign mostly defaults to print settings since that’s what it was originally built to do. Print uses CMYK instead of RGB. When you place an RGB file, InDesign displays it as RGB. When you add something like a drop shadow or a glow or whatever, InDesign shifts the colors to simulate CMYK colors, which typically desaturates out-of-gamut RGB values to their nearest CMYK equivalents.

Why InDesign doesn’t do this when first placing the RGB file instead of waiting until after you add a transparent element of some kind, such as an outer glow, I don’t know. In any case, setting the InDesign file up for web instead of print tells InDesign to keep the RGB values instead of simulating what it will look like in CMYK.

IT WORKED THANK YOUUU SO MUCH
I’ve been so mad for hours and so confused.
Thank you thank you

I’m glad it worked. :smiley:

Adding effects like transparency or outerglows etc will always cause InDesign to parse the image through an internal transparency flattener - which is why images look like they shift colour when transparency is added.

Nothing wrong with using EPS - but reopening your EPS in Photoshop it should flatten the entire file - so it makes it impossible to edit the EPS.

PSD or TIff is preferred - or where there is live text/vector shapes/vector masks - then PDF is preferred.

It’s about the correct file format for the problem.

A PSD or TIFF with live text layers will import ok into InDesign - but on output to PDF from InDesign (or to a print device) the text/vectors are rasterised to the native resolution of the PSD or TIFF.

This won’t happen with a PDF saved from Photoshop.

This is just how it works for placing things in InDesign from Photoshop.

I had a chat with a guy named Dov Isaacs who is the principle scientist at Adobe (or something along those lines) and he insists there’s no reason for InDesign behaving like that - it’s possible for a PSD or TIff to have live text output from InDesign - but it’s just not switched on. But there must be a technical reason it’s not.


@Just-B is correct - EPS is a format still supported by Adobe for legacy workflows and archaic systems.


Anyway - the problem you have is due to transparency being added to the image and InDesign trying to render the correct colours and doing a bad job.

I never ever fully trust InDesign viewing for colours and always look at the exported PDF.

When you use Print mode your document is setup as Edit>Transparency Blend Space>CMYK

When you use Web mode it’s Edit>Transparency Space>RGB

When you import an image in the wrong colour space into the wrong transparency space (and it has transparency) then the transparency flattener comes into play.

And it just doesn’t go a good job - or a better way to say it is - it is showing you there is an issue here that needs to be addressed.

Description for understanding what was going wrong was great, however, exporting it as pdf didn’t change it- it was still “desaturated” but I understand now what was going on. Thank you!

I remembered what we had going on and it was nothing to do with the solution found here. Our issue had to do with how some objects were grouped and ungrouped and what transparency effects were applied when. InDesign can do some crazy things with transparency.

What PDF settings? Are you exporting as PDF X4a?

So can the user :smiley:

Oh, I’m thoroughly convinced that some designers take great pride in finding some new way to screw up the rip. :wink:

I successfully managed to upsample an image with transparency before.

It wasn’t this method

But similar enough.