External Monitor Resolution w Laptop (Windows)


I use an HP Spectre laptop with Windows 10, and I connect it to an external monitor. I used to use a Dell monitor, but I felt like the resolution was poor, so a while ago I swapped it out for an Apple Cinema Display. Both monitors are used, and so kind of older technology, whereas the the laptop is new technology and has a hi-res 4K display.

I have it setup so the display is ‘extended’, with resolution and scaling as recommended. This is appears correctly scaled, however, the external display appears slightly choppy, most noticeably with text, and I will have issues like my Adobe tool boxes and layers windows are sometimes not correctly scaled while everything else is fine… so I wonder if there is a fix, or if that is just as good as it gets with this display situation.

My display settings are:

Thank you so much!

I’m not on a PC, but as far as I know all the Adobe apps have a UI Scaling option under their preferences, perhaps that would help if you updated within each app.

The scaling for different sized monitors in Windows is sometimes problematic. But you can try the compatibility settings.

  1. Find where the .exe file is for the application you want to fix (you need admin access).
  2. In Windows Explorer right click on the .exe file and select ‘Properties’ from the menu.
  3. Click on the ‘Compatability’ tab.
  4. Click on the button ‘Change settings for all users’
  5. Then click on the button ‘Change high DPI settings’
  6. At the bottom of the dialog box there is a checkbox you need to tick High_DPI_Scaling
    This will give you three options :- ‘Application’, ‘System’ and ‘System (enhanced)’
    Applications do their scaling in many different ways so the ‘Application’ setting usually gives very variable results but it’s worth a try.
    ‘System’ and ‘System (enhanced)’ usually give better results. Try all three and see if your monitor scaling improves. If it doesn’t then untick the checkbox to set it back to the way it was.

Experiment !

Hope this helps.

Thank you! I will have to fuss around with it and see if it helps.