Folder Locking Mac OS Question

I am having an issue with my Mac. I’ve tried searching for an answer online, but nothing shows up for this specific problem. I’m hoping someone here can offer some insight.

I installed a new app last week. It installed fine. Just like I thought it would.

I tried to install a new app yesterday (from the same company as the previously installed app, for what it’s worth), and the installer came back saying there was an error creating the folder. I called the company’s tech support thinking it was an error on their end. The tech support guy walked me through a few things.

If I click in the Applications folder and do Get Info, it shows up as being locked in the lower right corner. I click on the lock, enter my password, and it appears to be unlocked. However. if I close the Get Info and then immediately do another Get Info, it shows up as being locked again. It’s like the unlocking isn’t taking hold.

I’m attaching screen captures showing the sequence.

So it seems odd that the folder won’t unlock, and it seems odd that an app installed just fine last week, and I can’t install what would be a sister app today.

Any help is greatly appreciated.

I just hoped on my wife’s computer. It behaves the exact same way as far as the locking are re-locking.

It seems like when you install an app under normal circumstances, the installer asks for your password. The installer that I am using for second app is not asking for a password.

That’s weird. If it affects multiple computers, I’d think their tech support would have been aware of the issue. Don’t know if it would do any good, but have you tried unlocking the folder through the Terminal (never had a need to do it myself)?

That’s odd that the second installer isn’t asking for a password. I assume it’s a software company that you trust? Perhaps you could unlock it, then use the dropdown next to “everyone” and set it to “read & write”, then run the installer again and see if it works. If it does, set “everyone” back to “read only”.

The software is from Datacolor.

You could also (once again, if you trust it) create a root user account and install it that way.

©2019 Graphic Design Forum | Contact | Legal | Twitter | Facebook