Help with an Adobe CS6 issue

Being a semi retired free lance graphic designer, last year I transferred all my Adobe CS6 apps to a newer 27" iMac with MacOS 10.14.6 which is the last OS that allows me to use those apps. I only design a few projects a year. It took weeks to make that transition and had to find an Adobe person in India to move ALL related files from my old 24" iMac to the newer one. What a process!

The ONLY issue I have now is using fonts in InDesign CS6. Every few minutes the text box will go blank. When I move it a bit, the fonts come back and I can continue editing. If I go out of the app and come back, it works again. For a while! Very annoying and time consuming.

AND the drop down font palette in the menu bar will suddenly show no fonts at all. I try to scroll to the top and guess where the specific font is that I need to change - italic, bold, regular. If I get the wrong one, I try again until it’s the one I want.

There must be a setting or font conflict in CS6 that is doing this when the apps were transferred to my 27 iMac? But I can’t figure that out. Any ideas? Adobe won’t tell me as they want me to upgrade to CC.

CS6 is not supported under that OS.
Simple as that.

You can try a fresh download if you have activation from the Adobe servers located here


Before you do that
Try resetting your preferences:

Windows: Start InDesign, and then press Shift+Ctrl+Alt. Click Yes when asked if you want to delete preference files.
macOS: While pressing Shift+Option+Command+Control, start InDesign. Click Yes when asked if you want to delete preference files.
A dialog will appear asking to delete the InDesign Preferences, select ‘Yes’ on this dialog.
Further info and instructions here if needed:


And uninstalling and reinstalling rarely works - as when you uninstall it leaves traces of the folders and files, it doesn’t remove certain aspects. I know it’s stupid.

The Adobe cleaner tool was intended to help with corrupted installs. If that’s the cause it would help. I’ve mentioned elsewhere here that I gave my CS6 discs away because it became such an uphill battle to keep it stable as the OS changed. I’ve seen the behavior you’re describing before, but it’s been awhile so I can’t remember if I fixed it or it broke me.

How are you managing fonts? Does that play nice with CS6?

When Adobe Support helped me to transfer the CS6 apps to my new iMac, they told me OS10.14.6 would still work for me. Which is mostly does except this font issue. I’ll try your suggestion, but I do not want to try another download. I’m wary to make this worse!

dgolas, Years ago someone helped me remove Font Book altogether, and I managed fonts with Font Agent Pro. Worked great. Now with the OS10.14.6 install two years ago, I have Font Book again and it conflicts with FAP. Not sure how to manage this. If I just use FB for simple jobs, I hate the scrolling time to find the one or two fonts I need. What would you suggest to make this simpler?

I mostly asked just to because I wondered if the issue was being caused by your font manager. It seemed unlikely but, you never know.

I’d be reluctant to suggest a better solution, not knowing how one would work with CS6. I’ve been using one called Typeface I really like. It’s a good balance for my needs.