InDesign loses network connection on file then crashes

Hey guys! Sorry I have been absent for so long (actually had to create a new account, it was so long). I took a break from Graphic Design and opened up a few photo studios for a while. Ironically, I think this was before there was a photography forum on GDF, lol. I’m back now though, and hoping one of you might have a fix for a problem that’s dogged us a bit in the past but became a big full-blown disaster this morning.

On Mac OS Mojave, using a NAS server. Every Mac computer on the network has this problem now, but no Windows computers. It has done this randomly in the past (using InDesign 2018) and was fixed by recopying the folder of affected files, but this morning (using InDesign 2020) it suddenly started doing it to seemingly all of the many jobs in each of the 150+ client folders, and resaving or copying files is simply not viable. First, when opening a file it gives an error message that “The network connection was lost for the file FileName.indd, or the file was modified by another process.” InDesign will then crash, with the message, “InDesign quit unexpectedly.” After re-opening Indy, the file is available as a recovery, but of course we can’t just open and close InDesign multiple times just to open a file to work on.

It seems this problem has been reported many times to Adobe, and dismissed or told that they have found a solution to the problem then linking you to a KnowledgeBase link which is either missing or simply tells you that the problem is fixed without offering a solution. -_-

Here is an example of one such exchange (with an Adobe employee dismissing the problem at the end, to the annoyance of everybody else): <<Sorry, I guess I can’t include links yet. 10 post requirement, I’m guessing?>>

We have done all we could do with the network including reboots, changing Apple vs SMB vs Bonjour settings, manual network address connections, and everything else.

These are the screenshots of the error dialogues that pop up. Don’t blame me that it opened the first one on my other monitor which was browsing iStock… :smiley:

Thanks if you can give any insight to this problem!

Hey Ned! Welcome back! :slight_smile:

No idea what the problem is though :wink: I’m sure someone will be along with some help before long.

what are your file sharing permissions on the OSX?
check to see if they are enabled.
also check certifications and keychain.
your java script should be updated, but check that too

Windows did this many years ago, but i am not surprised Apple is conflicting with Adobe lately.

You don’t need a Java update with cc2020 on Mojave…

By any chance did you update your virus software lately?
We had this problem with Mojave because the virus update was made for Catalina. IT support had to revert to an earlier version, which cleared it up.

1 Like

Thanks Kat! Good to be back.

I tried turning on file sharing, and couldn’t find anything in certificates, EB.

No virus software that I know of, PrintDriver. :smiley:

Interesting update… Just had the same thing happen to an .indd file I opened from my own desktop (a blank template).

I had noticed when reading Adobe forum reports of this problem that somebody said he had it happen when opening a file on thumb drive too!

Also have updated InDesign, and even tried turning off Time Machine.
Opening files in an older version of InDesign does technically work, but that would be expected because it converts every file (oddly, even old files made in the same version) and doesn’t open the original file directly. All the files can be resaved and work properly, so converting it is no different. The mass of files however, would not make that a solution. :frowning:

Also tried disconnecting ethernet and connecting only through wifi… still no go. :frowning:

Oh, and regarding the file I opened from my desktop. Been trying a few, and I think the ones with a link to a network file still have problems, even if the .indd file is on my desktop.

Have you tried connecting using CIFS protocol? We had to do that for a while too. The IT guys don’t like it for some reason or other though. After we fixed the virus issue we’re back to SMB.

Indesign writes backup files when open. This is often an issue with some server setups and it definitely can be an issue with Dropbox. Been burned enough times in a lot of scenarios that now I just pull assets to my desktop. But I can do that as I print, and jobs are containerized. The files don’t have shared assets on a server.

I can’t help but wonder, where you say this is just a mac issue, if it has to do with the invisible .db files Apple OSX writes to files in use. That little feature still gives us server issues, unable to rename or move files sometimes. Sometimes logging off the server and logging back in works, other times it’s a computer reboot.

The server didn’t say anything about CIFS specifically, but it supports SMB 1,2, and 3 so we tried locking it to just SMB 3, which didn’t help. :frowning:

Good call on CIFS, glad you checked it.

It did make me find this link out on the internet that may or may not help the issue as well. It spoke of roping in your IT folks and looking in to excluding .indd or idml files from deduplication.

.ds files as mentioned earlier could certainly be an issue as well.

there is a Terminal command you can use to make the apple OS stop writing invisible .ds files. Problem is you have to redo the command with every little security update because it will go right back to doing it.

MacOS’s hidden junk files will definitely be the death of me!! Will look into excluding the Indy files from deduplication… Thanks!

Okay, what we did was to delete all hidden .db files off the server through a Windows system ('cause they can see the files the Macs make, unlike Macs, lol), then ran the terminal command line on each Mac computer to keep them from dumping more of them. Hopefully this works! Will keep you guys updated…

(There were over 3000 .db files on the server…)

Hey Ned! Gosh, sounds like a nightmare you are dealing with! I don’t have much to add…

I do remember experiencing issues with hidden *nix files like that when working on a windows server well over 10 years back. We were actively deleting those hidden files as they appeared anytime we ran into weird saving issues. The solution we had was to stop using a SMB server to host files made by *nix machines - I think IT switched the server OS to Linux and there was no more saving issues.

From my understanding, .ds, .db, .anything are valuable files for the *nix side of things that let OS know when files are being read/written/arranged for optimal file versioning, transferring and any additional file/folder preferences, something windows/smb does completely different. They can function without, but I’d expect this can cause file management issues on the Mac machines to some extent (probably related to color labels, file arrangements by folders, file type organization by folder, previews, immediate recall from server)

Well, the hidden .db file thing didn’t fix our big problem but it did fix another seriously annoying problem that we had forever, and that was Indy locking every file that’s ever been opened on the same day, so that they can’t be written over in InDesign (saying they are “in use”). The manual fix for that was to right-click on the file you wanted to write over, click on Move to Trash, then hit OK to save. Before the InDesign 2020 update we had the same problem but less far-reaching, locking files that were just recently updated or files that were actively highlighted in a Finder window. After the 2020 update, it started doing this to files which had been opened hours ago. Glad that’s fixed, at least!

©2019 Graphic Design Forum | Contact | Legal | Twitter | Facebook