MP4 mis-performs in Mac PPT

Hey everyone. I am using a Mac 2019 PPT with Mac OS Big Sur 11.5.2. I have a 2 second MP4 video of a graphic animation that I exported thru Media Encoder (single play, no loop). I inserted the MP4 into the PPT doc and selected it to “Autoplay” and “hide during show”. When I do a preview it plays just fine–the file ends staying on the screen until I go to the next slide. However, when I go to Presentation play mode, the video successfully plays through but then it disappears automatically–there are NO transitions or any animation affects on the video. There is no slide auto advance. I did a restart on the PPT, and I tried to reimport this 10 times and no matter how many preference changes I made, nothing solves the disappearing video. I even tried to trim the file tighter, but it always “disappears” when its finished playing. I tried the same MP4 file on new version of Keynote, and it performs flawlessly and remains displaying on the screen at the end of its single animation until i go to the next slide.

Please…any help would be greatly appreciated!!!

Have you tried this

    • Typically, most videos with a 640 x 480 resolution have a 4:3 aspect ratio, which is also the default aspect ratio for PowerPoint 2010 presentations. The default aspect ratio for presentations in PowerPoint 2013 and newer versions is 16:9. If the aspect ratios of the presentation and the video differ, your video will look distorted when it plays.

To specify precise height-to-width proportions of a video:**

  1. Under Video Tools, on the Format tab (PowerPoint 2013 or newer versions) or Options tab (PowerPoint 2010), in the Size group, click the Dialog Box Launcher Icon image.
  2. Click Size, and then under Scale, select the Lock aspect ratio check box.
  3. Under Size and rotate, enter sizes in the Height and Width boxes, or under Scale, in the Scale Height and Scale Width boxes, enter the percentage of size that you want, relative to the video’s original size.

Tip:* To prevent videos from skipping when they are played, under Scale, select the Best scale for slide show check box.

I found the solution after more fiddling. When you click on the video and view the playback preference settings, clicking on “Hide on Show” causes the video to disappear after it is complete. This feature seems strangely labeled. That preference setting wording really needs to be changed to something more obvious. Solved.