Oh my God! My Christmas machine is hopelessly stuck!

Oh my God!! My Christmas machine is hopelessly stuck!! :astonished:
Will you be able to keep Santas Factory running? Try it yourself!

Santa’s Factory Interactive (English)

Santa’s Factory Interactive (Dutch)

anim-santas-factory

After 60 seconds it still hasn’t loaded.

Thanks for your response.
Guess your machine is hopelessly stuck too then :wink:

What browser(version) and device are you using?

1 Like

Chrome, Windows 10 and everything is up to date :wink:

It worked for me (latest Chrome, latest Mac OS). It’s fun. I liked playing with it and discovering all the hidden little things that can happen. I’m impressed! :blush:

Is there a point to it or a goal that a user should be trying to achieve? Or is it just a matter of playing with the conveyer belt, the toys and the boxes to see what happens?

I nosed around a bit and Snow Wars and Winter Night load just fine. So I tried Firefox and Opera, same result.

This is what I see



Am I missing something? I see the “Tap on title page to start” what exactly do you mean? I’m on a PC, I can’t tap anything :wink: Is that the issue perhaps?

Hi RedKittieKat, the interactive is tested in all mayor browsers, different devices and operating systems, including Chrome under Windows 10 and is even running and almost instantly loading with ‘normal’ internetconnections on Internet Explorer 11 and iOS 8.3 which are pretty old (stone age even). Yesterday I did a test to let Chrome simulate the slowest 3G connection and even than it’s not even taking 60 seconds to load. I used very stable techniques and frameworks being used over the whole world by thousands of people and during a long time now and never heard this one before. When running inside Chrome on Windows 10 it’s loading in a blink of the eye here and the loader image doesn’t get the chance to show up. This is the first time I hear this complaint, while using these techniques for years now and continuesly testing it on all mayor browsers.

So I hate to tell you, but there seems to be something off in your system somehow. Thanks for your effort in trying out the Snow wars and Winter night animations. You say these are working fine with you and that could help us to see what’s happening here; Santa’s Factory is using webGL while the other two animations you mentioned are not using webGL. It’s a little difficult to debug what you are experiencing from here, but the only thing I can think of right now is that for whatever very odd reason your system have a problem using webGL causing the loading to hold. Which would be strange, because the browsers you mention are supporting webGL for a long time now. Maybe by accident some setting on your system is switched differently or there might be an issue on the graphical card on the field of webGL.

What might help is if you open chrome, go to ‘chrome://gpu/’ and post your result here. It shows a list of enabled and disabled features. Perhaps something is off with your graphics settings. That’s the only thing I can think of right now. Well… and it might also be worth turning off any adblocker or other addon in your browsers if you use them.

Thanks! Love hearing this stuff! :slight_smile: For this interactive Christmas Card doesn’t have an endgoal like a game-element, like another card on the website (Winter Night) has. That one is an advent calender and was at the time unlocking a window everyday befor Christmas resulting in a letter for a hangman sentence you’ll find when you click on the ‘A’-button.

This cards goal is to show the receiver they get an unlimited amount of presents, so many they have to put it in boxes because it continues over and over and over and… But I might add a game element later :wink:

Thanks for your response!

©2019 Graphic Design Forum | Contact | Legal | Twitter | Facebook