Outlined Font Rotate Issue

So I am prepping this artwork for pre-press, and whenever I rotate it to fit it on the press sheet, the R’s go funky as if I don’t have a closed path. I have checked to ensure all paths are closed, and none of the other compound paths in the word are doing what this R is doing. It doesn’t do this until I hit exactly 90 degrees rotation, which of course is what I need.

I can’t just put a shape overlay there of white as a workaround, because the background is an image with a screened PMS overlay.

Thoughts?

So… I was thinking “well this is happening at exactly 90 degrees so maybe 89.9 will work and no one would notice…” and it worked! Though if anyone has any insight because this does happen from time to time. Wondering if it’s a problem with the font before outlining.

Is it a proper compound path?

1 Like

That’s really strange. I’ve never seen that before. It only affects the R and only shows up when rotated to 90 degrees. That makes me very curious. Would you mind uploading the outlined vector file? If not, that’s OK, but I wouldn’t mind picking it apart.

1 Like

I don’t know about your issue, but mmm . . . bourbon.

1 Like

Here it is (: 89.99 even worked, but not 90, ha.

I believe so since all the other letters worked just fine! Everything’s closed up the way it should be… or so it seems, ha.

This is a known issue - in your Illustrator preferences go to Performance and turn off GPU performance.
It’s only a screen thing.

You can report bugs here
https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs?category_id=209149

It behaves exactly the same way on my end. I looked at every point on the outline, and everything is good. If you move the points on the right side of the counter, even the tiniest bit, the problem goes away.

I ran into a similar problem with an Adobe font a couple of months ago where if I outlined it, a weird nonsensical fill just like yours would appear. Also like your R, the problem went away if I moved certain points in the outline.

My best guess is that it’s some sort of hard-to-track-down math error in Illustrator that shows up in very specific situations. I opened the file in Affinity Designer and rotated it 90 degrees without any issues.


Follow-up: I just read Smurf2’s post. What he says seems right.

The node at the top of the R near the curve (when it’s rotated) that’s the issue

I added a new node to the directly above it and it fixed.

Capture 2

It seems to have something to do with this entire line of nodes beneath the green area. If any of them are moved enough, the problem disappears. I suspect it’s some sort of rounding or calculation error in the display of the object (It prints out on my laser printer just fine). Tilt the entire thing just a bit and the math-like glitch disappears.

image

And it’s linked to the GPU performance somehow.

It’s fine though - even if you do nothing and just make a PDF it looks good in the PDF.

A RIP error, of sorts.

I also rotated it - then moved that node from 2.1104 to 2.1105

@Smurf2 and @Just-B , you guys rock! I didn’t even think to consider GPU/CPU viewing. How ridiculous and random of an issue –ha. Thanks a ton!

2 Likes

©2021 Graphic Design Forum | Contact | Legal | Twitter | Facebook