Photoshop CC questions

OK, so! Remember when you had an image in your clipboard (ie. screenshot) and you opened PS and it automatically opened to whatever the clipboard’s dimensions were. PS CC doesn’t do it, I have to pick a size I think will work. Is this something in preferences I can change. It’s annoying the crap out of me.

It’s annoying the crap out of me too, so I’m glad you mentioned it. It’s one of those things that’s easier to work around at any given moment than it is to figure out. I don’t know if there’s a setting for it or whether it’s a Photoshop glitch.

1 Like

It still works the way you want . . .

IF you enable this option in Preferences:


Thank you @HotButton. It works! :grinning:

It should be in the recent

I’ve taken another screenshot to change the dimensions

Not all heroes wear capes HotButton!!! Thank you!

1 Like

Smurf, that’s for the last clipboard, not the current one. HotButton has the answer. Thanks though!

Just click New again from the side menu - blue button on the left.

It works.

I’m not sure what you’re suggesting, because it doesn’t work for me unless I do as @HotButton suggested.

Since @Designia and I ran into exactly the same problem, I’m sure now that it’s not just me running into this issue.

I’m on a Mac, which might be relevant (although HotButton is on a Windows machine). I don’t really have time to track this down, but when I capture part of the screen to the clipboard, Photoshop lists the size of the capture in the new document window, but it doesn’t honor the settings when it creates the new window. Instead, Photoshop opens a window to whatever size it was working on previously unless the user manually inputs new dimensions.

I’m not sure what has changed. The previous Mac keyboard sequence for a partial screen capture to the clipboard doesn’t seem to work as it used to, but my custom keyboard shortcut still works just fine when, but only when I make the adjustment that HotButton suggested.

I’ve always changed that default to what HotButton says, simply because I hate that new interface. Never had a problem with clipboard screenshots. I haven’t noticed a change in mac screenshot. Command shift 3 is the whole screen. Command shift 4 allows you to marquee the section of the screen you want. That’s about all I use. I do default them to land in a dedicated folder so I don’t cover my desktop when doing reference studies and saved as jpgs instead of .pngs

Same here. When I press Ctrl+N I want a new file, not a library of everything that ever existed.

1 Like

That saves the marqueed selection to a desktop file instead of the clipboard. What I meant was Shift+Control+Command+4.

I couldn’t remember the keys used at first because I had set up a keyboard shortcut years ago that copies the selection to the clipboard. But you’re right, the built-in combination does still does copy the clipped section to the clipboard now that I’ve played around with it and refreshed my memory.

However, the clipped dimensions are ignored by Photoshop without Hotbutton’s suggestion. I don’t remember that being the case prior to about a month ago.

Yeah, it’s recent. The last few weeks I’ve been moving everything over to a new Mac and upgrading and the clipboard dimensions quirk was one of the things driving me nuts. I don’t know if it was because the new computer has PS 2022 rather than 2021, or whether they made that change on one of the subsequent updates, but I’m glad to have a fix.

I put up screen shots. If you can’t follow that I can’t really help further.
It does still work - just works differently.

I typically have the legacy setup on all apps and detest the new file dialogue box.

I didn’t explain clearly enough. I said that Photoshop isn’t honoring the dimensions. I’ll try to explain better.

Just now, I made a square 496 x 496-pixel screen capture. I select New window in Photoshop and it shows the following, which is great because Clipboard is selected and it has the right dimensions.

However, when I click Create to create the new window, Photoshop doesn’t honor the 496 x496-pixel dimensions it listed. Instead, it opens a window that was the size of the previous window that I had open.

Changing Photoshop general preferences to "Use Legacy ‘New Document’ Interface, as HotButton suggested fixes the problem.

I’ll check it out - thanks. That’s new to me. Let me take a look later on.

Thanks again for explaining further.

If it’s a bug I’ll log it.

I just thought of something else and tried it to see if it would work. It did (at least for the one time I tried it).

Even though Photoshop isn’t honoring the dimensions of the object on the clipboard when it creates a new window, selecting one of the other size options, then re-selecting the clipboard option seems to reset it. A new file created after that opens to the correct clipboard dimensions.

I haven’t had time to try this today (swamped)

I believe this is a setting that you can adjust in the preferences of Photoshop CC. You should find an option allowing Photoshop to open images from the clipboard at their original dimensions automatically.

This was answered last Summer :wink:

Closing this up.