Photoshop's new constrain key is annoying

Photoshop has changed the shift key function, from constraining a transform to not constraining a transform. There is a way to fix it, by putting in a preference file into an invisible folder. It worked, and then there was another PS upgrade. I tried it again and now it doesn’t work. (And on another computer it works sometimes and not others). Has anyone dealt with this?

Adobe has posted a hack to fix this. It’s really a hack, not a preference click. You have to add a .txt file to the software as described here:
https://helpx.adobe.com/photoshop/using/transforming-objects.html#transform-scale-proportionally

Logically, the way they have changed it, is the way it probably should have been done I the first place. We have just all got used to doing thing arse about face. I’m sure it’s just a matter time and of becoming re-accustomed.

1 Like

The trouble is the scaling behavior in Photoshop has changed but hasn’t changed in Illustrator. It’s not a big deal, but as long as the two remain opposite one another, I’ll be tripping over it.

2 Likes

Flipping a long-standing feature 180° is one of the dumbest things a software company can do. But they did it.

I have still not updated my photoshop CC since they did this a couple versions ago… If they don’t fix this soon I’m canceling CC and going back to CS6, company-wide, for good. Sick of this crap.

The biggest issue Silence (and Adobe knows this) is that you can hold on to CS6, but eventually operating systems and newer machines won’t be compatible with CS6 (well, generally speaking … there are always hoops that one could probably jump through, but it will reach a point where it’s just not “reasonable”)

Very true, I know it works now because they have updated the installer (at least it did last OS) but they will never update the actual code so days are numbered. I still have 3 machines with MacOS mavericks just in case though :wink:

Absolutely. InDesign hasn’t changed either. Maybe one day they’ll all conform. (Or give the user the option to change it like Blender does with the right and left mouse clicks).

I am also annoyed with the new ‘feature’, but I can see why they did it.

If you scale a picture 99% of the time you wwant it to constrain/

After the script solution Adobe added a workaround in the preferences > general to have it work as it used to be.

But you must update to the latest version of Photoshp CC

Thank you Carlo for mentioning that checking the “Use Legacy Transform” box in the General Preferences will fix the annoying problem!

©2019 Graphic Design Forum | Contact | Legal | Twitter | Facebook