Question about Inkscape

I don’t use it very often but I noticed there’s a newer version so I downloaded it.

All the dialog boxes use a font I can’t read; can someone help ?

You’re a step ahead of me. The new version of Inkscape won’t even run on my Macintosh.

What you’re seeing is weird. All the letters are spelled out in Unicode. In modern digital fonts, each glyph is always identified by its corresponding Unicode hexidecimal value. The software application displaying the font is supposed to convert the Unicode values into the corresponding glyphs in the specified font. When the requested font isn’t available, the application is supposed to deal with it in some way, such as substituting a default font or returning an error.

In this case, not only isn’t Inkscape finding the correct font, it’s failing to do anything other than display the Unicode values. As I said, weird.

1 Like

I found this over on the Inkscape forum. I hope it helps :slight_smile:

1 Like

Yes, that’s exactly what I need. Unfortunately, I can’t navigate to Edit>Preferences because although I can read the menus and the options on the menus, I can’t read the text in the dialog boxes. Oh and there is no Preferences option on the Edit menu.

This is the Inkscape>Settings>Preferences>Interface dialog box;

The ‘Preferences’ option is on the ‘Edit’ menu, it is the one right at the bottom.

Hmm not on the Mac version apparently

A shortcut maybe?

On a Mac you’d find preferences in the Inkscape menu, or by pressing the keyboard shortcut shift, control, P, or command, shift, P on the Mac, or by choosing the last item in the commands bar.

Otherwise I would delete the whole thing and try a fresh download.

1 Like

Yeah I’d really want to try that hard to make a piece of software work… :grinning:

1 Like

Yep … sort of my feelings. I would try a few things … but then …


Yes, as I’ve already explained, despite the unreadable dialog boxes, I’ve been able to open the Preferences. Now I’ve figured out how to change the language (red circle) but it didn’t help. So it’s not that. FWIW I never use Inkscape, but I have a map file as .svg which is too big for my copy of Illustrator to open.

Flexisign and Coreldraw have no artboard nor size constraints, as illustrator does.
Sadly, neither are free.

That seems like there is some corruption somewhere. I seriously would pitch it and remove all trace from your system and do a fresh download. If it does it again … there is something on your machine that isn’t liking the program.

Sorry you are having such issues. I don’t have a MAC and I’ve never used Inkscape so I’m not much help. The only other thing I can suggest is joining that Inkscape forum. Maybe someone there will know solution :slight_smile:

what version of Illustrator are you using?

guessing you don’t have access to the extended artboard in the newer CC versions and/or can’t Place it rather than open it?

I’ve downloaded it again, no change. I never liked Inkscape anyway lol.

1 Like

I’m using a pre-CC version because I don’t (my boss doesn’t) want to go subscription. I never thought about Place instead of open. would that make a difference? would I still be able to edit it?

I redownloaded Inkscape and now it runs on my Mac running Ventura 13.5. What MacOS version are you running?

I don’t see the Unicode boxes. Everything displays correctly. I looked through the preferences/settings, and there are no settings regarding the software’s use of fonts for its dialog boxes.

Did you download the Intel or M1 version of Inkscape?

After you Place, with the object still selected, you’ll have an active Embed button on the control panel. After you embed, you should be able to edit.

1 Like

Adobes fault!

Same version of the os. I downloaded the mac intel version - several times now. I’m glad it’s working for you. Apparently there is a font problem with the Mac version so I guess I’ll wait for the next update >.<