RGB in InDesign

I’m building a city’s recreation guidebook. It’s a PDF booklet that lets the city’s residents know what city-sponsored recreation programs are available in the city.

It’s not designed for print — only for PDF distribution. Because of this, I want to use the larger RGB color space. InDesign, however, is insisting on limiting colors to CMYK.

In File > Document Presets and File > Document Setup, I’ve specified web instead of print. In Edit > Transparency Blend Space, I’ve sent it up for RGB instead of CMYK.

What have I missed? Any colors created in InDesign automatically convert to the CMYK gamut.

Is there a solution for this?

How are you outputting your PDF?
You have to set it in there as well

Hmm. You say any colors created in ID get converted to CMYK. Are you talking about created color swatches. I have no problem creating RGB colors, applying them to elements, and outputting an RGB PDF. I feel like I’m missing something in the explanation.

I was talking about any colors. Everything is always CMYK, no matter how I create them — swatches or one-off colors. I just noticed the top right-hand ribbon menu setting that is another way to specify “Digital Publishing,” but that doesn’t let me work in RGB either.

There must be some simple thing I’m missing, but Google searches turn up nothing other than what I’ve already tried. Come to think of it, this is the first time I’ve ever used InDesign and intentionally wanted to keep the RGB. It’s sort of starting to seem like Adobe never anticipated InDesign being used for RGB because everything regarding it is seeming like a retrofit rather than a built-in feature. Then again, if you’re seeing RGB, I’m obviously missing something.

It will actually be uploaded to innd.adobe.com for distribution, which keeps InDesign’s PowerPoint-like animation features intact for online viewing (another new thing for me). From there, people can download it as a PDF. How it’s converted there, I don’t know — haven’t gotten that far yet.

I just got it to work.

I had originally created the file as a CMYK document, then went through all the steps to make it RGB, but as I mentioned, despite the setting changes, the RGB values wouldn’t stick.

On a hunch, I created a new InDesign file and set it up from the beginning as RGB, which seems to have worked just fine.

I could be wrong, but I’m chalking it up to an InDesign bug.

You should be able to change it after the doc has been created. After the doc has been created, do:
File > Document Setup > Intent: Print
or
File > Document Setup > Intent: Web

You can toggle back and forth, and it will change all the swatches from CMYK to RGB and back again. And then when you output the PDF, do it as Interactive rather than Print, and it will keep the RGB colors… outputting as Print will convert the colors in the PDF to CMYK.

That’s exactly what I did, but for some reason, it didn’t work. Weird.

Ok - what do you mean by

and

I don’t understand this. Do you mean you still have CMYK swatches?

InDesign doesn’t use colour spaces - it’s colour independent until output.

Go to Edit>Assign Profile

You’ll see the below
image

RGB images will be treated as per the profile assigned.
CMYK images will work to the assigned profile.
You can discard the CMYK profile and use the current working space.

Which should be the RGB

Transparency Blend Space - is only for effects or transparency. If there’s no transparency in your placed files -
If you to go Preformatted textto Edit>then it doesn’t matter. But absolutely correct to set it up for RGB space.

I opened a print job with transparency last week and some numpty had set the blend space to RGB.

Here’s some light reading

Ok I was late to the party.

If the document was already created it already as a CMYK profile assigned to it.
Edit>Assign profile
or
Edit>Convert Profile

Assigning a different profile will preserve the InDesign swatches and will change the colours in images

Converting to a profile will preserve the colours and change the numbers accordingly.

Or something like that.

Yikes

I’ll try another way of explaining it.

The color picker screen captures below illustrate the problem. They’re from the InDesign file that was originally set up as CMYK but subsequently converted to RGB using all the steps I know about.

Notice the wording that says “Add CMYK Swatch.” I cannot get it to say “Add RGB Swatch” in the document that I converted from CMYK to RGB despite having taken all the steps I know about to convert the document to accept RGB values.

The top screen capture show how I’ve entered a color outside the CMYK gamut. When I close the Color Picker palette, then reopen it, InDesign has moved the values to what it feels are the nearest color values within the CMYK gamut.

In other words, when I took all the steps I know about to convert the CMYK document to RGB, I was able to enter RGB values into the color picker, but they would not stick and were converted to color values within the CMYK gamut.

When I subsequently created a new RGB document, the problem did not exist.

Apparently, there’s either an unknown setting I overlooked when converting the CMYK document to RGB or there’s a glitch in InDesign that doesn’t fully accept the change. I’m inclined to think there’s something I overlooked, but I don’t have a clue what it might be. Anyway, like I said, the problem isn’t there, now that I’ve recreated the document from the beginning in RGB.

Oh right - click into any of the RGB colour values - and the button should change to Add RGB Swatch.

Or export as an IDML file and re-open. Sometimes a file will just corrupt and that will usually fix it, if it doesn’t do dumb things to your formatting. I don’t usually have issues when using an IDLM from the same InD version. But there are some days I swear that some guy at Adobe logs into a random account and starts pushing the “Make it Broken” button.

Graphic Design Forum is a non-profit operation supported by our kind sponsors.

©2021 Graphic Design Forum | Contact | Legal | Twitter | Facebook