Unable to alter or delete files on server

…despite having full Read & Write Permissions

I can go to any file on the server - “Get Info” and I have full Read & Write Permissions. Still I am unable to replace old files with new versions.

Anyone know any common issues?

I don’t know enough about networks or servers to give details. Just hoping someone else may have something for me to try.

I’ve run into that glitch on Unix and Linux servers, but it’s been some time ago. I remember always needing to contact the server admin to get it fixed. I do remember, though, that in my case, it wasn’t something that could be fixed without server admin privileges. Could easily be a different problem from yours, though. Not much help. Sorry.

Are you on a Mac connecting to a Windows server?
Bump this in the morning and I’ll take a look at what we’re using for protocol now to do that. We had the same issue months ago after one of the new full Mac system upgrades (can’t remember which mountain.)

Again, if this is a Mac connecting to a Windows server

Don’t do any of this without your IT support people’s approval.

Go>Connect to Server
try changing the address to SMB://
If that doesn’t work, and it didn’t for us after one of the recent updates,
try CIFS://
That’s what we are having to use now.
Keep an eye on it for a bit. The only issue we have is the mac really doesn’t like working with really large image links over the server network, and re-saves seemed slower but I might be biased due to the large file nature of my work. Usually I drag my work onto my local desktop anyway, just because it is faster.

BTW, this all has to do with the mac leaving invisible .ds_store files laying around. The server won’t let you delete or change anything if it sees the folder/file “still in use.”
There is another workaround using Terminal to stop the Mac from writing invisible files, but we found that didn’t work for very long. Not sure why that is.
More info on that in this archived article.
I DO NOT KNOW IF THIS HACK WILL STILL WORK ON THE LATEST OS. Use at own risk.

A BIG Thank You!

I will forward this info to my boss who handles the servers.

Yes, it is Mac to Windows.

It’s cool. I think Driver got this one because what he describes is exactly what’s happening. Thanks! I’ll let you all know if/when something works.

Thanks Driver,
I tried both smb and cifs (we were already using cifs) but still have the same result.

I guess I’ll try to find a program that can find and clean out invisible .tmp and .ds_store files from the server. I used to love tech tool for this. If anyone knows any good software please let me know.

You tried the old restart right?
your computer, not the server.

That was the fallback workaround. Sort of clears its throat.

Out of curiosity, what OS are you on?

Running this script right now in Terminal with Admin password. It’s supposed to remove all ds_store files. It looks like it’s going to take all night lol.

sudo find / -name “.DS_Store” -depth -exec rm {} ;

©2019 Graphic Design Forum | Contact | Legal | Twitter | Facebook