What is causing these edges with this ellipse?

Hi! I tried two different ways to create an ellipse edge for a logo - one using a stroke but then later realizing it is not as symmetrical as I would have liked… the other option was to create the shape by taking circles of the same size and cutting out a little sliver (shown in white). Looked great until I zoomed in on the new blue shape and and saw this edge that I can’t seem to catch at all no matter what I do. It’s like a rectangle that hangs off of the end. Any idea what is causing this and how to get the desire shape with clean edges on the end??



Screen Shot 2022-05-06 at 8.56.33 PM

That’s peculiar. I suspect it’s a rendering glitch in Illustrator.

I duplicated the steps you described and got precisely the same thing. It’s very tiny, though, and only becomes apparent at the highest magnification levels.

I think it’s a glitch in Illustrator because when I copy and paste the object into Affinity Designer, the oddity isn’t there. Nor is it there when I save it to a PDF and blow it way up. I suspect it will disappear when printed too.

Ah, yes! Thank you!!

I’m not getting this - what are the steps to reproduce?


With stroke


with fill

Draw two overlapping circles, then use the pathfinder tool to separate the shapes.

The anomaly occurs every time, even when I skip the pathfinder tool and just use the pen tool to draw the curved shape. As I mentioned, it’s necessary to zoom way in before it becomes visible.

I’m using Illustrator 26.2.1 on a Macintosh running Monterey 12.3.1.

Did that. Don’t see the issue.

Are you using Adobe Ai CC? You have to zoom in Illustrator to see it; it disappears once you export the file. It happened to be both with pathfinder and with stroke.

I don’t see it. Can you give exact steps

Using Illustrator CC, create two solid circles with the ellipse tool. I used the same size, set the alignment and overlapped them just a sliver on the end. Use the pathfinder tool to click that little moon shaped sliver. Now cut the sliver object away from the other shapes to use. Wherever you decide to paste the sliver on your art board, zoom in ALL the way to the corners of the shape. Then you will see the glitch.

I’m not seeing it. Something else going on here I think. I tried thick cuts and thin cuts using a variety of offsets for the second circle.

Illustrator CC, MacOS El Capitan

1 Like

Who here is using Macs as opposed to Windows. Macs and Windows use different software for converting the postscript into what’s shown on the screen.

No issue here.

Illustrator 26.2.1, Windows 10

I’m using a 2019 MacBook Pro / MacOS Monterey
Illustrator CC

I’m pretty sure I did this on the Windows machine.

I just tried it on my wife’s M1 Mac laptop running Monterrey and got the same issue.

Since @StudioMonkey’s running El Capitan on a Mac and none of the Windows users here are seeing it, my guess is that it’s a Monterrey issue and how that OS is interpreting the PostScript on the display — essentially the equivalent of an inconsequential RIP error that probably won’t show up anywhere else. Of course, I could easily be wrong.

1 Like

Probably - I can try on the Mac tomorrow.

I can confirm it occurs on my Mac. I’ve seen this in the past on my mac as well. When you view it as outlines the point looks fine, but when viewed regularly it shows the odd rectangle-like point.

It’s definitely an odd screen rendering issue. If you add a stroke to the shape that is the same color as the shape, and set the stroke to align to the inside of the shape, the screen draw issue disappears.

1 Like